GM Inside News Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
359 Posts
Discussion Starter · #1 ·
I have a 2007 GMC Sierra Vortecmax with a factory remotr start.

I love the truck, however, within the last four months the trucks battery has gone dead.

FIRST time took the truck camping, didn't start it for two days= DEAD. Roadside assistance charges it, I let the dealership know "If it happens again let us know"

SECOND time took it camping again for two days. Same thing its DEAD (No cell coverage this time), luckily found someone with cables

(The truck was not being used for lights, radio, nothing while camping)

Take it to the dealership they say everything checks out but if it happens again dont get a jump we'll come out and look at it. Their Diagnosis " Maybe since your ONstar expired Onstar keeps waking up the modules"

(ONstar hadn't expired and thats a pretty stupid excuse considering how many vehicles are out there not getting dead batteries with or without ONstar services)

THIRD time, leave it for three days at my house, go to start it up, DEAD. Call them, they come out cant find anything wrong, jump it take it to the shop, They say "its your dome light, left on"

(Well, the dome light wasnt left on and even if it was every other vehicle I have ever owned has run down protection) So this time they disable my entry and exit interior lighting, Hell, I only paid $40,000 for the truck why should I expect the luxury of interior lighting

FOURTH time, the truck sits for 18hours wont start, this time it gets jumped and dropped off They keep it for two days cant find anything wrong.

Now I've just picked up the truck drove it for two hours on the highway turned it off, I restart it and the truck barely gets started the internal clock is reset as if the powere was disconnected and re-connected. I reset it go to the store and start it up again and it does that low power chug but does start.

Sorry for the long post but thats the whole story. Any ideas? I'm getting ready to drop off the truck with the keys. Like I said I love the truck but when I'm paying practically mortgage payments for the damn thing I expect it to start when I turn the key.
 

·
Registered
Joined
·
3,039 Posts
I assume they checked the altenator. But maybe you have a bad battery. Did they bother to check if the battery holds a charge if it is pulled from the vehicle? I know it's only a year old, but the battery could be bad. My folks purchased a brand new Subaru years ago, and within 6 months the battery was spent. It was replaced free of charge and they never had problems with it again. I replaced my OEM battery this year with a Sears battery and after 3 months my car wouldn't start. Or it would struggle to turn over and the clock kept resetting and the dash would go crazy if it did start. I brought it back to Sears, and they said that one of the cells was bad and it was only putting out 10 volts. They replaced it and I haven't had any problems since.

If that's not the problem, it must be something drawing off the battery once the truck is turned off. I can't believe the dealer wouldn't be able to find out where the parasitic loss was coming from. Good luck.
 

·
Registered
Joined
·
11 Posts
Supadave,
This has happened to me as well. I have a 2007 Silverado Ext Cab V-max Z71 with 40,000 miles. It happened once a week for 4 consecutive weeks, and has never happened again. The truck hasn't done this in 3 or 4 months now. Dealership never found anything wrong and the battery always passed the load/drain tests. Mine would drain down within 8 hours of me parking it in the morning after driving it to work. That evening, the battery would be completely dead and nothing would work. There is a TSB out for the dealership to reprogram the BCM because it can cause this issue (but this didn't help mine). Then, my airbag light came on and needed more reprogramming, but this didn't stop the battery draining either. Then the draining just stopped, and hasn't happened since.

The funny thing is, the last time it was at the dealership they washed it for me, and it quit draining the battery after that!! Maybe yours just needs washing:lmao:

This is the only problem I've had with this truck, and I love it more everyday:D
 
1 - 4 of 4 Posts
Top