GM Inside News Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2003 Impala I inherited when my dad past last year. The car only has 56000 miles and is in exceptional condition. About a month and a half ago I started to have problems with the trunk opening on it's own. After the lid opened you could still hear the release clicking like crazy. I have not yet had a chance to look at it so I just disconnected the wire going to the lock assembly in the truck.

Now the door locks are acting up. This started two days ago. When I came back and put the car in park the doors did not unlock. I was unable to unlock them with the switch on the door or the key fob. If I manually unlock one door and then put the car in drive the door will lock, but not unlock when shifted into park. The door locks started working normally yesterday, but started the same problem again today when I came back to work from lunch.

Does anyone have any ideas?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It does have an alarm that was added by the dealer, probably through out side vendor. This was done when the car was new in 2003. I have also notice that there seems to be a clear cycle to the problem.

Put car in drive, then park, system is fine.
put in drive and park again, system is fine.
Put in drive again, and now when put in park doors do not unlock. Will not unlock with switch on door, or key fob.

I have not figured out yet how long the car must sit, but the next time I drive the car the system functions properly.

There are no codes in ECM or BCM.
 
1 - 4 of 4 Posts
Top