GM Inside News Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Hey all, I'm driving a 1999 Sunfire 2 dr. coupe with the power sunroof and the 2.2L engine. I've owned it for approximately 10 months, and it has been a wonderful first vehicle. I acquired it from my father as a "parting gift" as he has gone abroad to work.

Now, to the point. Before I received the car, my father had two of the four strut mounts replaced. I cannot remember which ones were replaced, but I do remember that two of them were. Over the last week or two, I have noticed an unusual snapping sound coming from underneath the car somewhere. It always seems to happen when the weight of the car shifts from the front to the back. For example, when I am on the throttle, gaining speed, and when I let off the pedal, I hear a snapping noise.

I'm just wondering if this is a sign that the other two strut mounts have given up on me, or could it suggest something more serious? Any help would be greatly appreciated.
 

·
Registered
Joined
·
1,733 Posts
check the muffler and the whole exhaust system. something like that happen to my friends cavalier and i looked and her muffler was messed up.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
Thank you sir, I believe you were right. My exhaust seems kind of loose, so the noise must be from the exhaust hitting up against the bottom of the car. Your help was much appreciated!
 

·
Registered
Joined
·
4,660 Posts
It could be strut mounts, but typically the sound is more "knocking" than snapping. Let us know what you find.
 
1 - 5 of 5 Posts
Top