GM Inside News Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,061 Posts
Discussion Starter · #1 ·
I have a 2004 Pontiac sunfire with what i think is around 98,000 KM on it. The Odometer reading was working fine this morning when I went to school. I didnt drive my car all day but when i got back into my car and looked down I noticed my odometer reading wasnt working. In certain sunlight i can read my mialage on it, the numbers show up but i guess its not back lit. Is there a bulb or LED behind the numbers that makes it glow? If so how much would it cost to get replaced?
 

·
Registered
Joined
·
1,671 Posts
It is backlit. In my father's Cavailer, I know that it was covered under warranty, but they did have to replace the whole gauge cluster.
 

·
Registered
Joined
·
18,488 Posts
ugh. Thats going to be expensive to replace.
Well you have some options:

1. Do nothing (easy)

2. Remove cluster, disassemble it on the kitchen table, and change the tiny bulb that costs like 25 cents. Maybe you need to solder it or it might actually be in a socket. Much more involved than option 1 but not much more expensive.

3. Remove cluster, replace with exchange unit. Basically 50% of the work of option 2 but several orders of magnitude more expensive ;)



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
1,061 Posts
Discussion Starter · #7 ·
Heres a curve ball for you.

Out of frustration of other things. Lastnight I punched my horn twice fairly hard and the light came back on. But when i shut the car off and turned it back on it wasnt on again.

I also notice the knobs for the vents on the ac, they glow dimly when my lights are on, but if i hit the plastic bezel under the lights they go back to normal brightness. Perhaps a loose connection in the harness is causing this?
 

·
Registered
Joined
·
1,671 Posts
Perhaps...more likely it is just a burnt out bulb that made contact ago (although briefly). Just like a lightbulb...
 

·
Registered
Joined
·
1,061 Posts
Discussion Starter · #9 ·
Well, I hit the top of the dashboard a couple of times and the odometer came back on and has stayed on for a few days now. So perhaps its fixed. haha. Good old hitting things to make it work.
 
1 - 9 of 9 Posts
Top