GM Inside News Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
6,105 Posts
Discussion Starter · #1 · (Edited)
So, first, i wanna say whats up. i havent been around much as of late, things have been crazy since i graduated in may- i just got a new job in june, started earlier this month, and i just finished moving- all in the last month and a half or so. things are going real good as of late, until now....

to the problem at hand. i was driving today, and my brake system warning light came on, and the DIC said "service brake system". so what does this mean? is it really serious? all the manual says is to pull over and see if the light goes off, if it doesnt, have it towed to the dealer. it doesnt say what the potential problems were. the light did go away while i was driving, but it came back when i turned the truck on, and then went off again while driving. when the light came, the brake pedal did become firmer like the manual said it might, but it still stopped fine. anyone know? i hope its just that i need some fluid or something, i just had the brakes done at 50k miles (im now at 66k)- brand new fronts, didnt touch the rear though (which are drums). any help is appreciated.
 

·
Registered
Joined
·
6,105 Posts
Discussion Starter · #2 ·
noone knows anything about this? really?

at least it hasnt come back since yesterday, but it would nice to know what happened, or could be happening.
 

·
Banned
Joined
·
8,969 Posts
IDK, but that really surprises me that you already have to get brake work done on a Silverado with that few miles. Something doesn't sound right. I would at least have GMGoodwrech take a look at them.

Techs seem to be in very short supply as of late- sorry you're not getting much assistance.
 

·
Registered
Joined
·
2,209 Posts
well, the red brake light only comes on in a few situations,
1. low brake fluid switch detects low brake fluid or is shorted.
2. the hydraulic brake system has a leak in it somewhere and the pressure differential switch in the combination valve closes its contacts which will trigger the light to come on.
3. you may have a problem with the emergency brake, whether it be slightly engaged and you may not know it, or possibly a switch fault or short.
or sometimes an ABS fault can trigger the light on.

i would check the brake fluid level first, see if its low.
then if its low, i would check it for leaks. if it isnt low then start by checking visual things, make sure no e brake cables are hung up, and that the e brake is fully engaging and disengaging. then if that doesnt work, try pumping the brakes see if the light turns on and off. if that doesnt work, then you have a electrical problem, be it a switch/sensor or wiring.

also try banging on the brake fluid reservoir. can be like coolant level switches, get stuck in one spot, like if the brakes get worn, for instance and the fluid is low due to brake lining wear, if that switch gets stuck on, then it will stay lit up.

also make sure your pedal is good, and maybe even crack a few bleeders just to make sure fluid is getting to that part of the hydraulic circuit.

also you can check for codes if you have access to a tech 2.
 

·
Banned
Joined
·
158 Posts
your truck could have a vacuum pump attached to the booster where the vacuum line enters booster,this is called supplemental brake assist,it was on some 05 and 06 models,if a problem occurs in this system you can recieve a service brake system warning on the dic although this is not the only possible cause.as far as what triplex said above your vehicle does not have a combination valve and the metering portion of the brakes are done by the abs unit,its called dynamic rear proportioning.
 

·
Registered
Joined
·
6,105 Posts
Discussion Starter · #9 ·
thanks guys for the help. i havent been able to check anything yet, been busy, still settling in along with work. but some good news is that it seems like its was a freak thing in that thats the only time it has happened thus far. ill let you guys know what happens once i take a look
 

·
Registered
Joined
·
6,105 Posts
Discussion Starter · #10 ·
so i just checked (i finally remembered while taking the garbage out), and the level at is at max. so that would mean no leak and its not low. so, looks like ill be going down the checklist. we'll see how that goes.
 

·
Registered
Joined
·
1 Posts
Fluid level actually makes sense for some of these situations. Not the ABS light though, just the brake light. This only happens to me when I apply harder than normal brake force and harder than normal acceleration, the brake light comes on, DIC says "Service brake system", then in about 1.5 to 2 seconds shuts back off and goes on it's normal way. No ABS light. My thoughts are if it was a vacuum leak or sensor, it would be on ALL the time. I haven't lost any brake capacity as of right now. For some reason, I couldn't figure out why only harder than normal accel / decel would do that, but that does point to the fluid level. Strangely enough is, I just did a front brake job on the truck, so unless something is leaking (which as much as I hate to make assumptions, I assume not) or the reservoir would have bled dry by now, or I would have seen a puddle or wetness on the tires.

I had to wait until the tornado warning was over and the storm subsided for a bit, but I went out and checked my fluid. Go figure, it was low. Now I have to look for where the fluid all went. Like I said, I just did a front brake job on the truck, so perhaps there IS a leak someplace. If you are trying to troubleshoot this problem, go for the simplest solution first.... check your brake fluid.
 

·
Registered
Joined
·
2,667 Posts
One of the company's Renault Megane did the same thing (in my case brake system warning light came on after a harder braking)... They had it checked and nothing was found, next time I drove the car it didn't come on again, though those cars (and my own Megane wagon) have the crappiest brakes I have ever found in a car... Either that or i got used to too good brakes with the MINI I owned before...

Could you have experienced some electronic gremlin?
 

·
Registered
Joined
·
6,105 Posts
Discussion Starter · #16 ·
Oh boy this is an old one lol. Well im currently at 170,000 miles and It never came back on....so I think im in the clear haha.

sent with Autoguide from my portable mini-computer
 
1 - 16 of 16 Posts
Top