GM Inside News Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
604 Posts
Discussion Starter · #1 ·
I love my 04 GTP Comp G, but I've been having some minor electrical system quirks. Has anyone else had these happen?

The 6 disc Monsoon sound system buzzes in all speakers when the key is on or engine running. It also will buzz with the key off for about 20 seconds after the driver door is opened or closed. When running the buzz with go away if the headlights are turned on.

After a long slow sideways slide on ice the traction control and stability control both turned off and then had service messages come up for both systems. (after restarting the car the service messages have not returned).

And this is the real freaky one. This morning (January 21st) I noticed the display shows that it's "Thursday January 21" when it's really Wednesday on every calendar I've seen! For those of you not familiar with the system, you enter the year, month, and date, and the day of the week is automatically figured out. Well, if I enter dates in December 2003 it shows the correct day of the week, but now the days I've entered in January 2004 all show one day ahead of what it really is. I'm going to try to enter some dates in for later in this year to see if the day of the week is correct, but I havn't had that chance yet.

Anyway, I'm interested in hearing if anyone else has been having these types of issues. Overall I still love the car, but I'm getting a bit annoyed! :angry:
 

·
Registered
Joined
·
29 Posts
The buzzing could be a bad ground or lack of on the stereo.
the calander could be screwing up because it is leap year(feb29)
going back to the dealer is never fun...but the warrenty is nice...
nice car.....enjoy :)
 

·
Registered
Joined
·
337 Posts
my 04 Gp gt2 has none of thoes issues at all for what it's worth. my calendar is just fine but i wonder if you have am and pm backwords on the radio that would change the day around and if it happend to be set in the wrong year it would be off by a day too.
 

·
Registered
Joined
·
604 Posts
Discussion Starter · #7 ·
GM is aware of the calendar problem... The letter from GM is below. Also, I'm still hoping to get that buzz fixed in my Monsoon 6 disc system... I'd hate to think I spent the extra money for a stereo that buzzes all the time (unless the headlights/dashlights are on)


Thank you for contacting the Pontiac Customer Assistance Center. We appreciate you taking the time to write us in regards to your 2004 Pontiac Grand Prix programming concerns.

Pontiac Motor Division has announced a concern with 2004 Pontiac Grad Prix models equipped with a 6 disc CD changer. Owners of vehicles equipped with this option will experience a concern when programming day, and date information into the Drivers' Information Center. Wrong day information will be displayed with correct date information. This is a radio software issue that conflicts with preprogrammed calendar leap year information. To correct this condition, customers will have to have their radio exchanged by their dealership. Delco is working with suppliers to obtain a validated replacement supply of radios. Customers are not being referred to dealers for replacement until Delco has replaced all existing radios in stock for exchange. Owners will be notified at that time. This will be done in the near future. We apologize about any inconvenience this may cause.
 

·
Registered
Joined
·
1 Posts
Hey, I just got an 04 GTP with the Comp G package as well. My sound system has a buzzing sound, and also if I hit a bump just right, the passenger door panel speakers have a whining noise that goes up and down with the engine revs, but hit another bump and it goes away. Just wondering if you heard anything more.
 

·
Registered
Joined
·
1 Posts
I don't have the buzzing that some of you have described, but after just a few months of ownership my cd player seems to be dead. Everything was working well until winter hit (though it could just be a coincidence). After driving over some bumpy, snow and ice covered roads, the cd player would randomly skip, and then, after a few days, it completely stopped playing. All I get if I press play is the whirring noise like it's loading a cd, but this will go on for some time and then "Player Error" will display. It also won't eject any of the disks that I have in the system. Dealership says that the player is dead and wants upwards of $300 for a replacement.

I came here because I don't know anything about cars and/or stereos, and I wanted to get someone's input on this issue. A friend of mine thought that perhaps if we remove the unit and the disks that are stuck inside that it may fix the problem. We just haven't had time or money to work on it yet. Any thoughts before I go ahead and take it out?
 

·
Registered
Joined
·
802 Posts
I don't have the buzzing that some of you have described, but after just a few months of ownership my cd player seems to be dead. Everything was working well until winter hit (though it could just be a coincidence). After driving over some bumpy, snow and ice covered roads, the cd player would randomly skip, and then, after a few days, it completely stopped playing. All I get if I press play is the whirring noise like it's loading a cd, but this will go on for some time and then "Player Error" will display. It also won't eject any of the disks that I have in the system. Dealership says that the player is dead and wants upwards of $300 for a replacement.

I came here because I don't know anything about cars and/or stereos, and I wanted to get someone's input on this issue. A friend of mine thought that perhaps if we remove the unit and the disks that are stuck inside that it may fix the problem. We just haven't had time or money to work on it yet. Any thoughts before I go ahead and take it out?
Wait a couple of days till it gets warm, I thought mine was going to explode on me each time I changed the track, that's how loud the gears were inside, but as soon as it thawed and got warmer outside, the grinding went away. I guess the coldness makes parts shrink and misfunction.
Also if you adjust the air blower to blow through the middle hole right above the radio on the highest setting for about 5 minutes that fixes it too sometimes.

Happy Hunting!
 
1 - 11 of 11 Posts
Top