08 wave Please help

  1. Welcome to GM Inside News Forum General discussion forum for GM

    Welcome to GM Inside News Forum - a website dedicated to all things GM.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join GM Inside News Forum today!
     
Results 1 to 2 of 2

Thread: 08 wave Please help

  1. #1
    Walking
    Join Date
    Jan 2019
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    08 wave Please help

    So my 2008 pontiac wave is missing and sometimes staling while ide. It ony misses or surges when it's hot, it will work perfectly when it's cold. After about 15 min of driving the problem starts. It was giving codes p2135(throttle position sensor) and p0340(crankshaft position sensor) Both sensors were replaced as we as the throttlebody. All new parts. But the problem persists. However the codes are gone. No codes are showing now. So obviously that wasn't causing the issue. Also changed the pugs and wires which also did nothing.*

    The engine wont miss if it's in park or neutral, it's nice and smooth. There is some oil in the spark plugs but it's been there for years and never caused any issues. When i got the car the seal on top of engine was bad and leaking oil which i replaced(no oil leaking now). I can see that causing a problem now all of a sudden. My battery is bad which my mechanic says could cause issues if it wont accept the proper voltage from the alternator but why would it only cause issues when it's warm? I can't see that being the problem.

    Any ideas?

  2. Remove Advertisements
    GM Inside News
    Advertisements
     

  3. #2
    6.2 Liter LS9 Supercharged V8 richmond2000's Avatar
    Join Date
    Nov 2009
    Location
    Winterpeg
    Posts
    8,286
    Thanks
    8,524
    Thanked 1,476 Times in 1,064 Posts
    My Ride
    2014 RAM 1500 HEMI

    Re: 08 wave Please help

    a bad battery can cause an engine miss as the battery acts as a "filter" to the power to remove surges and such and is it is worn out it can cause many wierd issues

    I would try forums dedicated to that family of cars
    chevrolet aveo T200


    Chevrolet Kalos (T200)
    Chevrolet Lova (T250)
    Chevrolet Nexia (T250)
    Daewoo Gentra (T250)
    Daewoo Kalos (T200)
    Holden Barina (T200/T250)
    Pontiac G3 (T250)
    Pontiac G3 Wave (T250)
    Pontiac Wave (T250)
    Ravon Nexia (T250)
    Suzuki Swift+ (T200/T250; hatchback)
    ZAZ Vida (T250)

  4. Remove Advertisements
    GM Inside News
    Advertisements
     

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2