Trans problem

  1. Welcome to GM Inside News Forum – General discussion forum for GM

    Welcome to GM Inside News Forum - a website dedicated to all things GM.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join GM Inside News Forum today!
     
Results 1 to 2 of 2

Thread: Trans problem

  1. #1
    1.8 Liter ECOTEC
    Join Date
    Dec 2010
    Posts
    56
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Trans problem

    My niece has this 2006 impala that kicks hard when accelerating sometimes, it has the 3.5. I drove it, it does it when you are slightly moving and then you accelerate. What could the problem be?

  2. Remove Advertisements
    GM Inside News
    Advertisements
     

  3. #2
    6.2 Liter LS9 Supercharged V8 MrCritical's Avatar
    Join Date
    Aug 2008
    Location
    South Of The North
    Posts
    6,363
    Thanks
    0
    Thanked 7 Times in 6 Posts

    Re: Trans problem

    History of car? Accidents? Mileage? Engine or transmission mount? Engine miss? Transmission slip?

    Need some details. Service engine light on? Had a tune up?

  4. Remove Advertisements
    GM Inside News
    Advertisements
     

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2