2010 Equinox 4cyl 1LT gas mileage getting poor at 130k? Radio not showing up (led)?

  1. Welcome to GM Inside News Forum – General discussion forum for GM

    Welcome to GM Inside News Forum - a website dedicated to all things GM.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join GM Inside News Forum today!
     
Results 1 to 3 of 3

Thread: 2010 Equinox 4cyl 1LT gas mileage getting poor at 130k? Radio not showing up (led)?

  1. #1
    2.4 Liter SIDI ECOTEC markm75's Avatar
    Join Date
    Oct 2009
    Posts
    136
    Thanks
    0
    Thanked 0 Times in 0 Posts
    My Ride
    Equinox/2010

    2010 Equinox 4cyl 1LT gas mileage getting poor at 130k? Radio not showing up (led)?

    I have a 2010 Equinox 4 cyl that i purchased in nov of 2009.. it had the motor completely replaced at around 60k miles.

    Now it has 130k miles on it. About 6 months ago the dealer thought the throttle body, i believe it was, was getting clogged up and needed cleaned as when i would start it it hesitates or starts up then shuts off.

    I still have this same issue today from time to time.

    I also keep track of the mpg on the avg economy setting and i've noticed about 2-4 mpg less than say 1 year or more ago, though i did switch tires about a year ago to a slightly different model, though i'm thinking this wouldnt have a drastic effect on things (i still keep them around 33lbs cold). I typically run on eco mode

    I'm wondering if maybe changing the spark plugs and fuel filter might help.. the air filter was changed around 6 months ago.

    --

    The other issue i'm having is that the radio doesnt light up all the time... i can get it to come on by hitting a button on the radio controls (it still works even though not lit up).. i guess minor but i'm hoping not the start of a bigger issue..

    Any thoughts?

    Thanks in advance
    2010 Equinox 1LT 4cyl AWD
    Personal Review:Hidden Content
    Tech, the Universe, and Everything: Hidden Content

  2. Remove Advertisements
    GM Inside News
    Advertisements
     

  3. #2
    6.2 Liter LS9 Supercharged V8 TruckMan's Avatar
    Join Date
    Sep 2007
    Location
    Fort Worth, TX
    Posts
    6,285
    Thanks
    4,566
    Thanked 2,684 Times in 1,299 Posts
    My Ride
    2015 Sierra Denali 6.2L

    Re: 2010 Equinox 4cyl 1LT gas mileage getting poor at 130k? Radio not showing up (led

    Plugs are cheap and easy to replace. Same with MAF and TB cleaner. I'd do all three to start. Fuel filter is not likely to impact economy, and it's likely in your tank - so hard to switch. If it's inline outside of the tank, go for it. Though I did have a weak fuel pump that made my truck difficult to start. That's an option as well, but I wouldn't think it would impact economy so much as just engine performance.

    But I'm thinking your tires may be at least part of the culprit. Slight differences in rubber compounds, thread pattern, and weight can have a 3%-10% impact on efficiency. Try checking the specs on the old and new tires to see what the differences were. Unless you got exactly the same tires. Are the new tires taller by any chance? What were/are the sizes of the old/new tires?
    GMI Site Rules: 11. "Trolling", or making posts with the sole intention of creating problems on the forums is obviously against the forum guidelines. We define trolling as a member that appears to have the sole purpose of posting just to spite the majority of the site or cause flame wars in threads they participate in. PLEASE respect differing opinions on the site at all times!

  4. #3
    2.4 Liter SIDI ECOTEC markm75's Avatar
    Join Date
    Oct 2009
    Posts
    136
    Thanks
    0
    Thanked 0 Times in 0 Posts
    My Ride
    Equinox/2010

    Re: 2010 Equinox 4cyl 1LT gas mileage getting poor at 130k? Radio not showing up (led

    Quote Originally Posted by TruckMan View Post
    Plugs are cheap and easy to replace. Same with MAF and TB cleaner. I'd do all three to start. Fuel filter is not likely to impact economy, and it's likely in your tank - so hard to switch. If it's inline outside of the tank, go for it. Though I did have a weak fuel pump that made my truck difficult to start. That's an option as well, but I wouldn't think it would impact economy so much as just engine performance.

    But I'm thinking your tires may be at least part of the culprit. Slight differences in rubber compounds, thread pattern, and weight can have a 3%-10% impact on efficiency. Try checking the specs on the old and new tires to see what the differences were. Unless you got exactly the same tires. Are the new tires taller by any chance? What were/are the sizes of the old/new tires?
    I called the dealer for the "worst case" pricing.. its 135 for the plugs change out and 66 for the fuel filter, combined around 195 with taxes and a 10% discount applied.

    More stats for fun: My old stats for going to work had me on eco mode getting about 23.6 mpg arriving at work on average.. now i seem to be anywhere from 19.5 to 22.8 (fluke maybe) at best (these are 70% highway and 30% city over 20 miles distance). Its rated at i think 20 or 21 city and 31 highway.. a trip heading up north on the highway a good 45 minutes mostly highway recently was very poor id say.. around 23 mpg.. pretty sure old values might have been about 26 or so, though the route maybe was a steady climb heading even for the highway interstate.

    The old tires were tiger paw uniroyal touring 225 65r17 660ab 102T.. (put on nov 2013 at 72,204 miles).

    The new tires are mastercraft avenger lsr touring 640 or 780aa rated (unsure).. they were put on feb of 2016 (at 117k miles, got about 2.4 years and 45,000 miles out of them and could have gone a little further). I didnt buy from this link but here are the new ones specs. (same 225 65 R17).. at this point i'm at 130k. (these were about $200 cheaper than the uniroyals were in 2013).

    I will say, these new mastercraft seem to be wearing much faster than the uniroyals, unfortunately.
    Last edited by markm75; 11-23-2016 at 11:49 AM.
    2010 Equinox 1LT 4cyl AWD
    Personal Review:Hidden Content
    Tech, the Universe, and Everything: Hidden Content

  5. Remove Advertisements
    GM Inside News
    Advertisements
     

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Powered by vBadvanced CMPS v4.1.2