P0341 Cam Position Sensor

  1. Welcome to GM Inside News Forum Ė General discussion forum for GM

    Welcome to GM Inside News Forum - a website dedicated to all things GM.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join GM Inside News Forum today!
     
+ Reply to Thread
Results 1 to 7 of 7

Thread: P0341 Cam Position Sensor

  1. #1
    454
    454 is offline
    3.6 Liter SIDI V6 454's Avatar
    Join Date
    Jul 2005
    Posts
    1,186
    Thanks
    0
    Thanked 0 Times in 0 Posts

    P0341 Cam Position Sensor

    Hey I just got done installing my 1.9:1 rockers and upon startup got a P0341 code. Since the rockers themselves wouldn't necessarily trigger this code, I've come to the conclusion that i may have bumped a plug or disturbed a wire in the process of installation. Anyone have any ideas of where to look first?

  2. Remove Advertisements
    GM Inside News
    Advertisements
     

  3. #2
    2.8 Liter Turbocharged V6 dr.gizmo's Avatar
    Join Date
    Jun 2006
    Location
    Chicago suburbs
    Posts
    770
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: P0341 Cam Position Sensor

    Start by going over your work carefully looking for anything out of place. What is the make, model , year, and engine? It is hard to be more specific when you don't know what you are working on.
    30 Year Gm Dealer Tech.
    GM World Class Tech with 9 certs.
    ASE Master with L1; 12 certs. total

  4. #3
    454
    454 is offline
    3.6 Liter SIDI V6 454's Avatar
    Join Date
    Jul 2005
    Posts
    1,186
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: P0341 Cam Position Sensor

    Quote Originally Posted by dr.gizmo View Post
    Start by going over your work carefully looking for anything out of place. What is the make, model , year, and engine? It is hard to be more specific when you don't know what you are working on.
    Sorry its a 1996 Buick Riviera with the Series II supercharged 3800. After looking over the vac lines and plugs that i disassembled it all seems to be in the correct orientation.
    Last edited by 454; 08-17-2009 at 06:36 PM.

  5. #4
    2.8 Liter Turbocharged V6 dr.gizmo's Avatar
    Join Date
    Jun 2006
    Location
    Chicago suburbs
    Posts
    770
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: P0341 Cam Position Sensor

    Are you sure you didn't pinch a wire under the valve cover by the ignition coil? All the ignition wiring runs through the harness right there. The cam and Crank circuits run to the ignition module first then get sent from there to the PCM through that harness. That is the only area I can think of that overlaps the cam sensor circuits with a rocker job.
    30 Year Gm Dealer Tech.
    GM World Class Tech with 9 certs.
    ASE Master with L1; 12 certs. total

  6. #5
    454
    454 is offline
    3.6 Liter SIDI V6 454's Avatar
    Join Date
    Jul 2005
    Posts
    1,186
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: P0341 Cam Position Sensor

    Small update, went to my friend's house to let her dad take a look at it since he's a mechanic, and although his scanner didn't find anything else out, he did notice that the Cam Sensor Plug was a little bit wet. I figure it was from removing that coolant pipe from the tensioner assembly. So he was able to unclip it and clean it off, but wasn't able to plug it back in because he was wearing gloves since the engine was hot. This seems like a pretty good explanation for the problem and I'll try to get it plugged in in the coming days and hope it solves the issue.

    The wiring looms dont look to be pinched by the VC's but I'll take a close look tomorrow.

  7. #6
    454
    454 is offline
    3.6 Liter SIDI V6 454's Avatar
    Join Date
    Jul 2005
    Posts
    1,186
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: P0341 Cam Position Sensor

    Cleaning and replugging it in did not work, so it looks like I have some fun hours with a multimeter ahead of me...FML.

  8. #7
    2.8 Liter Turbocharged V6 dr.gizmo's Avatar
    Join Date
    Jun 2006
    Location
    Chicago suburbs
    Posts
    770
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: P0341 Cam Position Sensor

    You are going to need to get a diagnostic chart and a schematic for that code and your car. At least you have a hard code, most of the time I get these as an intermittent and all we can do is try to guess as to what the problem is or drive it for days and hope we can catch what is glitching for the .5 seconds it takes to set the code. Good Luck!
    30 Year Gm Dealer Tech.
    GM World Class Tech with 9 certs.
    ASE Master with L1; 12 certs. total

  9. Remove Advertisements
    GM Inside News
    Advertisements
     

Quick Reply Quick Reply

Register Now

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2