'98 Safari - 4.3 Vortec - NO SPARK

  1. Welcome to GM Inside News Forum – General discussion forum for GM

    Welcome to GM Inside News Forum - a website dedicated to all things GM.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join GM Inside News Forum today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: '98 Safari - 4.3 Vortec - NO SPARK

  1. #1
    Walking
    Join Date
    Apr 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy '98 Safari - 4.3 Vortec - NO SPARK

    '98 GMC Safari - 4.3 vortec; 140K; No previous codes or issues; Started after sitting for 8 hours in heavy rain. Ran for 90 seconds (just long enough for me to reach the parking lot entrance), and as I pressed the gas pedal to accelerate into traffic, the engine shut down. No stumble, or bog, no odd sounds, just like the ignition had been turned off.
    Crank, no start. After 3 or 4, 10 second cranking sessions, fuel could be smelled from the tail pipe.
    pulled coil wire from cap and placed end next to intake bolt, cranked and NO SPARK.
    pulled Dis. cap, and cranked. Rotor turns. attached DVOM to outer wires for cam sensor and verified ac hertz while cranking.
    I need ignition system trouble shooting tips.
    I have no spec.'s or procedures for checking the coil, or otherwise checking the rest of the ignition system, but I have a Fluke 78, and I am good with directions. GM Tech's - Help me find my missing sparks

  2. Remove Advertisements
    GM Inside News
    Advertisements
     

  3. #2
    Walking
    Join Date
    Apr 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: '98 Safari - 4.3 Vortec - NO SPARK

    I also checked the ECM fuses - OK
    Crank sensor - 2 mV on center wire, pulsed AC hertz while cranking.

    I decided to throw a ICM at it, and presto, it worked. I drove the van for a 30 minute test drive, and then drove 5 miles to work. Van sat for 8 hours, and then when I came outside....

    Crank No Start - AGAIN

    Suggestions?

  4. #3
    2.8 Liter Turbocharged V6 73ChevelleSS's Avatar
    Join Date
    Mar 2005
    Posts
    902
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: '98 Safari - 4.3 Vortec - NO SPARK

    I guess at this point you have to start all over again.I would want to also put a fuel pressure gauge on it.Fuel pressure is very critical on a Vortech.The pressure should be like 60-65psi on key up and not bleed down.
    GM World Class Certified
    ASE Master Tech
    ASE Truck Tech
    ASE Service Consultant
    ASE Advance Engine Performance L1
    GM MOE 2005 Gold
    Gm MOE 2006 Gold

  5. #4
    Walking
    Join Date
    Apr 2010
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Angry Re: '98 Safari - 4.3 Vortec - NO SPARK

    No rain last night. Before I rolled it off of the trailer this morning, I tried again to start it. It runs... Very frustrating. I will start testing grounds this weekend, and hope that something obvious shows up. "Intermittent drivability problem" has to be the most frustrating 3 words ever. followed closely by "I have ....(insert STD here)".

  6. Remove Advertisements
    GM Inside News
    Advertisements
     

Quick Reply Quick Reply

Register Now

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2