2001 Astro van won't start

  1. Welcome to GM Inside News Forum – General discussion forum for GM

    Welcome to GM Inside News Forum - a website dedicated to all things GM.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join GM Inside News Forum today!
     
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: 2001 Astro van won't start

  1. #1
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Question 2001 Astro van won't start

    When you turn the key, you hear the fuel pump coming up to pressure. The starter goes, but it won't turn over. Tried ether, no go. Local shop says it may be the ignition control module, but it's expensive to replace on an IF ($80 to $135). The ICM gives a yellow spark and the local shop tells me it should be blue. Does anybody have any suggestions? You all were a big help to me last July on my AWD issue (I got plugged in - a $750 fix so I'm waiting till it goes out totally).

  2. Remove Advertisements
    GM Inside News
    Advertisements
     

  3. #2
    7.0 Liter LS7 V8 Premium Member
    Join Date
    Sep 2004
    Location
    *
    Posts
    4,467
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: 2001 Astro van won't start

    It could be a passlock issue...which would require a new ignition cylinder lock case. Does the security light flash???

  4. #3
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 2001 Astro van won't start

    I would wholeheartedly agree with that but we're getting spark from the spark plug test. No security light is on.

  5. #4
    7.0 Liter LS7 V8 Premium Member
    Join Date
    Sep 2004
    Location
    *
    Posts
    4,467
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: 2001 Astro van won't start

    If it fails to run...then i'd guess an ICM too....how are the plugs/wires/cap/rotor???

  6. #5
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 2001 Astro van won't start

    In new condition. Guess we'll bite the bullet and go get an ICM now. We'll let you know. Thanks!

  7. #6
    7.0 Liter LS7 V8 Premium Member
    Join Date
    Sep 2004
    Location
    *
    Posts
    4,467
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: 2001 Astro van won't start

    Quote Originally Posted by rk5154
    In new condition. Guess we'll bite the bullet and go get an ICM now. We'll let you know. Thanks!

    Well...I can't tell you otherwise, other than a good guess!

  8. #7
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 2001 Astro van won't start

    We picked up an ICM for $67.99 tonight. Will let you know if it worked tomorrow. Thanks for rolling it around with me.

  9. #8
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Talking Re: 2001 Astro van won't start

    I'm back. The ICM made no change whatsoever. I have fuel traced all the way to the engine, no problem. Pressure is there too. Is it possible it's the O2 Sensor? Exactly where is that located? As always, your help is appreciated!

  10. #9
    7.0 Liter LS7 V8 Premium Member
    Join Date
    Sep 2004
    Location
    *
    Posts
    4,467
    Thanks
    0
    Thanked 1 Time in 1 Post

    Re: 2001 Astro van won't start

    Coil OK? You are sure about fuel pressure BEING ok? Did you check it?

  11. #10
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Unhappy Re: 2001 Astro van won't start

    I cracked the lines and fuel squirted everywhere. Hooked a sparkplug to a wire and we're getting good spark. It just seems like it's not injecting or getting fuel. Is there a particular way to check the pressure other than seeing it squirt?

  12. #11
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 2001 Astro van won't start

    I disconnected the harness from the coil. I have definite power on the pink wire, but not the black and white wire. What does that mean?

    Thanks!

  13. #12
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 2001 Astro van won't start

    Checked all the grounds and fuse as you suggested. No problems there. So I guess it's time to tow it to a garage. Thanks a million for walking me through that far.

  14. #13
    7.0 Liter LS7 V8 King Riffle's Avatar
    Join Date
    Nov 2005
    Location
    Wisconsin's lower Fox Valley
    Posts
    4,887
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 2001 Astro van won't start

    www.astrosafari.com

    If anybody can help you, they can. Heck, they might just convince you to swap a V8 into your van

  15. #14
    Walking
    Join Date
    Jul 2005
    Posts
    10
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 2001 Astro van won't start

    Thanks to everyone so far, but I still can't get it to start after dealing with all your suggestions. Now someone at the parts store said to check the coolant sensor. Any idea where to find that on an 01 Astro AWD?

  16. #15
    Walking
    Join Date
    Nov 2005
    Location
    New York
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: 2001 Astro van won't start

    the sensor should be on the driver side in the side of the head... i believe toward the rear.... below the vortec on the valve cover......
    ---->Automotive Student<----

    1979 Trans AM (in the works)

  17. Remove Advertisements
    GM Inside News
    Advertisements
     

Quick Reply Quick Reply

Register Now

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2